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Adobe After Effects Log to Linear Workflow

Below are guidelines for Log to Linear workflows within After Effects CC 2019. The camera source will dictate which method you
need to use. After Effects has dedicated color profiles for some cameras such as Alexa and Sony, but none for Red or Canon.

For sources with available profiles in AE (e.g. Alexa or Sony), please use Method #1 - AE Color Managed.

For DPX, EXR, or Quicktime plates created for VFX, please follow Method #2 - Cineon Converter or Method #3 - OCIO (OpenColor
IO). One thing to note, Method #2 is a general Log2Lin conversion that doesn’t have the ability to choose specific camera color
spaces. Method #3 - OCIO will allow you to select specific color spaces, but does require a 3rd party plug-in. Please contact the post
supervisor if VFX work is to be done to an unconventional source.

If you are working with the native RED (R3D),  Canon, or any camera source that After Effects does not provide a camera profile,
you’ll want to use Method #3 - OCIO. We would recommend making VFX plates in lieu of working with the camera source.  Also, this
plugin is from an open source 3rd party. The process to install can be a little techinical, so

If TBD Post is providing the plates for VFX, the final rendered frames that are sent back should have no color/gamma shifts when
compared to the original plates.

Method #1 - AE Color Managed Log2Lin Workflow

1. Go to File > Project Settings…
2. Select the ‘Color Settings’ tab.
3. Set ‘Depth’ to ‘32 bits per channel (float)’.
4. Set ‘Working Space’ to ‘sRGB IEC61966-2.1’.
5. Check box for ‘Linearize Working Space’.
6. Select ‘OK’. This will setup the project to work in linear space.
7. You will now need to ensure that each asset is properly tagged with its native colorspace.
8. Import your assets, and right click on the asset in the project window.
9. Select ‘Interpret Footage’ > ‘Main…’.
10. Under the ‘Color Management’ tab, select the appropriate color space for your camera source.
11. Ensure that ‘Interpret As Linear Light’ is ‘Off’.
12. Create a new comp based off your clip’s metadata. Preserving the timecode of the source is preferred.
13. Your image may look dark in the Comp Viewer. You’ll want to ensure that your viewer is showing you the image in a

viewable color space. Select View > Use Display Color Management. If you’d rather use a supplied LUT or a camera
specific LUT, refer to the ‘Viewable LUTs’ section below.

14. For any new assets brought into the comp, you will want to make sure that the colorspace is tagged properly.
15. When you are ready to render back to log, add comp to the ‘Render Queue’.
16. In the ‘Render Queue’, select ‘Render Settings’ for the added render job.
17. Ensure that ‘Color Depth’ is set to ‘32 bits per channel’ and select ‘OK’.
18. We prefer to receive final frames as DPX, EXR, or ProRes4444.
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DPX Output

1. Open the Output Module Settings.
2. For ‘Format’, select ‘DPX/Cineon Sequence’.
3. Select the ‘Color Management’ tab.
4. Make sure that ‘Output profile’ is set to the same profile that was set on the imported source.
5. Select the ‘Cineon Settings…’ button.
6. Ensure the ‘Preset’ is set to ‘Full Range’.
7. Ensure ‘Units’ is set to ‘Decimal’.
8. Set ‘Bit Depth’ to ‘10-bit’.
9. Click ‘OK’ and ‘OK’ again to close the Output Module window.
10. Select ‘Render’ to render your comp.
11. Import your rendered frames and compare the render vs. the original Log source. There should be no

gamma/color shifts when comparing the two.

EXR Output

1. In Output Module, set the Format to ‘Open EXR Sequence’.
2. Under ‘Video Output’, ensure that ‘Depth’ is set to ‘Floating Point+’.
3. Click ‘Format Options’.
4. Set ‘Compression’ to ‘Zip’.
5. Click ‘OK’.
6. Select the ‘Color Management’ tab,
7. Make sure that ‘Output profile’ is set to the same profile that was set on the imported source.
8. Select ‘Off’ for ‘Convert to Linear Light’.
9. Click ‘OK’.
10. Select ‘Render’ to render your comp.
11. Import your rendered frames and compare the render vs. the original Log source. There should be no

gamma/color shifts when comparing the two.

Quicktime ProRes4444 Output

1. Open the Output Module Settings.
2. For ‘Format’, select ‘Quicktime’.
3. Select ‘Format Options’.
4. Select the ‘ProRes 4444’ for ‘Video Codec’.
5. Click ‘OK’.
6. Ensure ‘Depth’ is set to ‘Trillions of Colors’.
7. Select the ‘Color Management’ tab,
8. Make sure that ‘Output profile’ is set to the same profile that was set on the imported source.
9. Select ‘Off’ for ‘Convert to Linear Light’.
10. Click ‘OK’ to save your settings.
11. Hit ‘Render’ to render your comp.
12. Import your rendered frames and compare the render vs. the original Log source. There should be no

gamma/color shifts when comparing the two.

Method #2 - Cineon Converter Log2Lin Workflow
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1. Go to File > Project Settings…
2. Select the ‘Color’ tab.
3. Set ‘Depth’ to ‘32 bits per channel (float)’.
4. Set ‘Working Space’ to ‘sRGB IEC61966-2.1’.
5. Check box for ‘Linearize Working Space’.
6. Select ‘OK’.
7. For all log footage being used in the comp, apply the Effect > Utility > Cineon Converter effect.
8. In the ‘Effect Controls’, make sure ‘Conversion Type’ is ‘Log to Linear’.
9. Ensure that ‘Highlight Rolloff’ is set to ‘0’.
10. Ensure that ‘10 Bit Black Point’ is set to ‘0’.

11. For any new assets brought into the comp, you will want to make sure that the colorspace is tagged properly.
12. Your image may look dark in the Comp Viewer. You’ll want to ensure that your viewer is showing you the image in a

viewable color space. An easy way to do this is by using AE’s Display Color Management. Select ‘View’ > ‘Use Display
Color Management’ to enable this option. If you’d rather use a supplied LUT or a camera specific LUT, refer to the
‘Viewable LUTs’ section below.

13. When you are ready to deliver shots, you will need to put the shot back in its source color space.
14. Add an adjustment layer to the top layer of your comp. Label the layer ‘Lin > Log’.
15. Add the Cineon Converter effect to the adjustment layer.
16. Select ‘Linear to Log’ for ‘Conversion Type’.
17. Ensure that ‘10 Bit Black Point’ is set to ‘0’.
18. With the adjustment layer on, the image should look log. Disable Display Color Management as the image may look

overly bright with it on.
19. Refer to the ‘Render Output’ section below for steps to render your shot for delivery.

Method #3 - OCIO Log2Lin Workflow

1. You will first need to install the OpenColorIO plug-in. You can download the AE plug-in at opencolorio.org.
2. You will also want to make sure to download the Sample Configurations. This will give the ability to select camera

specific color spaces.
3. Make sure to restart After Effects after installation.
4. Go to ‘File’ > ‘Project Settings…’.
5. Select the ‘Color’ tab.
6. Set ‘Depth’ to ‘32 bits per channel (float)’.
7. Set ‘Working Space’ to ‘sRGB IEC61966-2.1’.
8. Check box for ‘Linearize Working Space’.
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9. Select ‘OK’.
10. For R3D clips, you will need to ensure that the proper R3D settings are set before rendering. For non-R3D footage,

skip to Step 3.

a. Right-click the R3D clip in the project window and select ‘Interpret Footage > Main’.
b. Click ‘More Options’.
c. Click the ‘Reload from RMD’ button.
d. Select ‘IPP2’ in the ‘Image Pipeline’ dropdown.
e. Set ‘Color Space’ to ‘REDWideGamutRGB’.
f. Set Gamma Curve to ‘LOG3G10’.
g. Check that ‘Saturation’ is set to ‘1’.
h. Check that ‘Contrast’ is set to ‘0’.
i. Set Output Transform ‘Color Space’ to ‘REDWideGamutRGB’.
j. Set Output Transform ‘Gamma Curve’ to ‘LOG3G10’.

k. Click OK.
l. Select the ‘Color Management’ tab and uncheck ‘Preserve RGB’.
m. Set ‘Output profile’ to ‘Working Space - sRGB IEC61966-2.1 (linear)’.
n. Set ‘Interpret As Linear Light’ is set to ‘On’.
o. Click OK to save your settings.

11. For all log footage being used in the comp, apply the Effect > Utility > OpenColorIO effect to that layer.
12. In the OpenColorIO effect, select ‘aces_1.03’ for ‘Configuration’.
13. Select the input log color space of your camera for ‘Input Space’.
14. Select ‘Utility’ > ‘Utility - Linear - sRGB’ for ‘Output Space’.
15. For any new assets brought into the comp, you will want to make sure that the colorspace is tagged properly.
16. Your image may look dark in the Comp Viewer. You’ll want to ensure that your viewer is showing you the image in a

viewable color space. An easy way to do this is by using AE’s Display Color Management. Select ‘View’ > ‘Use Display
Color Management’ to enable this option. If you’d rather use a supplied LUT or a camera specific LUT, refer to the
‘Viewable LUTs’ section below.

17. When you are ready to deliver shots, you will need to put the shot back in its source color space.
18. Add an adjustment layer to the top layer of your comp. Label the layer ‘Lin > Log’.
19. Add a OpenColorIO effect to the adjustment layer, select ‘aces_1.03’ for ‘Configuration’.
20. Select ‘Utility’ > ‘Utility - Linear - sRGB’ for ‘Input Space’.
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21. Select the input log color space of your camera for ‘Output Space’. With the adjustment layer on, the image should
look log. Disable Display Color Management as the image may look overly bright with it on.

22. Refer to the ‘Render Output’ section below for steps to render your shot for delivery.

Viewable LUTs

In some cases, it is preferred to view your work through a viewable LUT as opposed to AE’s Display Color Management. If
there was a LUT developed on-set or by the colorist, that can be used within the comp. If no LUT exists, you can use one of
the LUTs supplied for your camera source as an approximation of actual contrast and color.

1. To setup a viewable LUT, add an adjustment layer to the top layer of your comp.
2. Name the layer ‘Viewable LUT’.
3. If you were supplied a LUT, add the Effect > Utility > Apple Color LUT effect and navigate to the location of your LUT.
4. If you do not have a LUT, you can add an OpenColorIO effect to the adjustment layer and select from one of the

provided LUTs.
5. Select ‘aces_1.03’ for ‘Configuration’.
6. Select the input log color space of your camera for ‘Input Space’.
7. For ‘Output Space’, select ‘Output’ > ‘Output > Rec.709’.
8. You will want to turn off this Viewable LUT layer when rendering shots for delivery.

Render Output

1. When you are ready to render back to log, make sure the Lin > Log adjustment layer is enabled. As a safeguard,
disable the ‘Look’ layer to ensure that the Viewing LUT isn’t baked into the render.

2. Add comp to the ‘Render Queue’.
3. In the ‘Render Queue’, select ‘Render Settings’ for the added render job.
4. Ensure that ‘Color Depth’ is set to ‘32 bits per channel’ and select ‘OK’.
5. We prefer to receive final frames as DPX, EXR, or ProRes4444.

DPX Output

1. Open the Output Module Settings.
2. For ‘Format’, select ‘DPX/Cineon Sequence’.
3. Select the ‘Color Management’ tab.
4. Make sure that ‘Output profile’ is set to ‘Working Space - sRGB IEC61966-2.1’.
5. Select the ‘Cineon Settings…’ button.
6. Ensure the ‘Preset’ is set to ‘Full Range’.
7. Ensure ‘Units’ is set to ‘Decimal’.
8. Set ‘Bit Depth’ to ‘10-bit’.
9. Click ‘OK’ and ‘OK’ again to close the Output Module window..
10. Select ‘Render’ to render your comp.
11. Import your rendered frames and compare the render vs. the original Log source. There should be no

gamma/color shifts when comparing the two.

TBDPOST.COM | 512.772.1552 5



Updated 2019-11-08

EXR Output

1. In Output Module, set the Format to ‘Open EXR Sequence’.
2. Under ‘Video Output’, ensure that ‘Depth’ is set to ‘Floating Point+’.
3. Click ‘Format Options’.
4. Set ‘Compression’ to ‘Zip’.
5. Click ‘OK’.
6. Select the ‘Color Management’ tab,
7. Make sure that ‘Output profile’ is set to the same profile that was set on the imported source.
8. Select ‘On’ for ‘Convert to Linear Light’.
9. Click ‘OK’.
10. Select ‘Render’ to render your comp.
11. Import your rendered frames and compare the render vs. the original Log source. There should be no

gamma/color shifts when comparing the two.

Quicktime ProRes4444 Output

1. Open the Output Module Settings.
2. For ‘Format’, select ‘Quicktime’.
3. Select ‘Format Options’.
4. Select the ‘ProRes 4444’ for ‘Video Codec’.
5. Click ‘OK’.
6. Ensure ‘Depth’ is set to ‘Trillions of Colors’.
7. Select the ‘Color Management’ tab,
8. Make sure that ‘Output profile’ is set to the same profile that was set on the imported source.
9. Select ‘On’ for ‘Convert to Linear Light’.
10. Click ‘OK’ to save your settings.
11. Hit ‘Render’ to render your comp.
12. Import your rendered frames and compare the render vs. the original Log source. There should be no

gamma/color shifts when comparing the two.

Please contact the post supervisor for any questions, clarifications, or special circumstances regarding your project.

Thanks!
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